*** EOS Upgrading *** PLEASE STICKY

For everything about the EMU sampler EXCEPT preset and cord creations.

Moderators: ezman, stu, Ole

*** EOS Upgrading *** PLEASE STICKY

Postby ikechukwu » Thu Nov 24, 2005 11:33 pm

If this is useful, please sticky this for the newbs...

It's worth updating the OS to at least 4.61 as new features and bug fixes are available in this version....I went ahead straight to 4.70, and this is how it's done.

EOS 4.0 through 4.10 users need to load Ultra Prep to enable your sampler to read compressed files. EOS 4.5 users need only to install the new version of EOS 4.6 or EOS 4.7 (flashprep not required).

First of all, you'll need to download these two files to your computer's C drive (make sure it is C and not desktop). Get them off EMU's website under Emulator Ultra Operating Systems

http://www.emu.com/support/files/downlo ... Platform=1

Once the files are downloaded....In Windows, Click Start, then Run and type CMD in the Run box.

A DOS window will open....Make sure the prompt says C:\ If it doesn't, type cd.. and press enter (repeat until the prompt is C:\ )

Now, insert a (good) blank floppy disk in the drive...Make sure it is good by formatting it. Type format a: and press enter

When formatting has finished, type FLASHPRP.exe then press enter. When asked what drive to use, press a.

Take this disk out and label as 'Flash Prep Disk'

Insert another floppy and format it.

When formatting has finished, type EOS470.exe then press enter. When asked what drive to use, press a

Take this disk out and label as 'EOS 4.70'

Put the 'Flash Prep Disk' floppy in the EMU, turn the EMU on and wait....You may have to press the Enter button when the screen is blank to start the upgrade process.

When all disk activity has finished (make sure you give it enough time as disk access is sloooow)....Take the disk out and put in the 'EOS 4.70' disk.

Press Enter to get the update started....I believe the machine will reboot itself when it has finished....

One tip....Whenever disk activity seems to finish or hang, press Enter...For some reason I had to do this a number of times to fully update the OS...The bad thing is, the display doesn't give you any feedback so you have to just guess at what stage the process is at....Saying that, it's not difficult to do and should take no longer than 10 mins.

Posts: 41
Joined: Thu Feb 10, 2005 4:44 pm

Postby foxcorner » Fri Dec 30, 2005 6:16 am

Thanks for the info, though I don't think your procedure's
basically any different to what I tried. I've got a new thread
I just opened asking how to make this work... :???:

Since my e6400 Classic is running 4.62, I won't need to do
the flash-prep step before updating to 4.70. My problem is
that even when I apparently successfully wrote a floppy using
EOS470.EXE, my Emulator won't read it at boot time.

I had to go through hoops just to write the floppy:

* Had to download a tool that would let me format it at 1.68MB

* Had to run EOS470.EXE on a system running Windows 98!

No good, though.

So, if there's something I'm doing wrong; or if you think
my Classic won't take the upgrade to 4.70; or if you think
I need to run flash-prep anyway, I'd love to know.

I really want to get onto 4.7 for the FAT support.

Posts: 14
Joined: Fri Dec 30, 2005 1:18 am
Location: Colorado, USA

Postby dr_k » Fri Dec 30, 2005 12:03 pm


i think eos 4.70 is only for the ultra modells. Since EMU-Support only shows the 4.62 version
http://www.emu.com/support/files/downlo ... Platform=1

I recently updated from 4.01 to 4.62 with the same procedure via floppy as you described, and it works fine.
After that i installd a 8,7 GB SCSI Harddisk intern which was properly recognized and formated by the system.
(unfortunatly i could not hear anything out of my emu because of the volume-knob, but this is another thread...)

So i think FAT support is already in EOS 4.62.

volker :thumbs:
Posts: 7
Joined: Thu Dec 29, 2005 11:43 am
Location: Germany, old europe

Postby foxcorner » Fri Dec 30, 2005 6:01 pm

Hallo noch ein Mal, Volker. :)

No, I don't think FAT is supported at 4.62. I expect
that it formatted your hard drive with EOS file system,
not FAT file system.

I still want to try to get 4.70 onto the Classic. Or, if I
can find a way to create an EOS-format CDROM on my
Mac or my PC, that would solve my problem too.

I am trying the Free version of Chicken Systems Translator,
but without success. :sad: Using it, I can translate
SoundFont2 files into EOS format, but I can't put them
onto a virtual EOS CD. I don't know why it doesn't work.

Posts: 14
Joined: Fri Dec 30, 2005 1:18 am
Location: Colorado, USA

Postby Ole » Sat Dec 31, 2005 2:30 pm

foxcorner wrote:
I still want to try to get 4.70 onto the Classic.

Sorry, but that is impossible. Eos 4.62 is the final eos for non-ultras.
Posts: 340
Joined: Sun Aug 21, 2005 1:20 pm

Postby foxcorner » Sat Dec 31, 2005 6:04 pm

OK. No problem. Thankfully, I finally figured out how to
get ChickenSys Translator (Free version) to build EOS-format
virtual drives, so I now have a vehicle for building CD's
that my e6400 Classic will read.

Hence, I don't need FAT support, so I'll give up on 4.7.

Posts: 14
Joined: Fri Dec 30, 2005 1:18 am
Location: Colorado, USA

Postby volltreffer » Sun Jan 22, 2006 11:37 am

Chicken Sys FREE??? Didn't even know about it...

Just am in the process of downloading... How do you create CDs with it??

thanx in advance...

:cry: imply depressed :cry:
Posts: 63
Joined: Sun Jan 25, 2004 7:24 pm
Location: Munich, Germany

Postby foxcorner » Sun Jan 22, 2006 9:00 pm

Hi Axel,

I'll reply when I have a little more time. I'm going to
the airport soon. ;)

Posts: 14
Joined: Fri Dec 30, 2005 1:18 am
Location: Colorado, USA

Postby sturoc » Wed Feb 15, 2006 2:18 am

Hey Guys,
Using E6400 classic w/ cpu-ram 1mb/ flash 2mb
Can I up to 4.6 ?
If so:
I am running Win 2000 pro I tried to do the floppy EOS upgrade routine :
when disc is formatted it says format is FAT.
Is this okay? If not, how do I change this?
Also where is the flashprp.exe command typed into ? DOS or "Run" window or elseware? Am I missing something?
Posts: 150
Joined: Fri Jun 17, 2005 6:36 pm
Location: Colorado USA

Postby ikechukwu » Mon Feb 27, 2006 4:28 pm

Sorry, I've been away for a while...Moving.

Right, yes EOS 4.70 won't work in non ultras as has been said.

Sturoc, download the files and place them in the C:\ drive....I said C:\ drive (root folder) before, because any other place, and you have to start typing long paths and bollocks....So place both files in the C:\ (root) folder.

Format floppys as FAT (no other format is supported as default).

Open a run box (Windows key + R)

Enter the command CMD

When the window opens, enter the command CD.. until the display prompt reads C:\>

Now follow the tutorial above from the type FLASHPRP.EXE

The only thing else I can think that may be wrong is that your downloaded files may be bad, in which case, you should download them again.

Hope that helps.
Posts: 41
Joined: Thu Feb 10, 2005 4:44 pm

Postby sturoc » Tue Feb 28, 2006 4:09 am

Will give it another try Thanks for the updated info.
Posts: 150
Joined: Fri Jun 17, 2005 6:36 pm
Location: Colorado USA

Postby poeticproductions » Wed Mar 01, 2006 6:44 am

hey y'all... been having a few probs with my e6400 ultra... just want to know:

when i'm updating my OS, at the end of the flashprep, the sampler asks burn to floppy? i chose no...

then at the end of the OS update, it asks Burn to flash? first i said yes (then had the problems) now i've done it again and said no, and it seems to be working ok...

anyone know what i'm supposed to answer to these questions?

thanks... :slayer:
Posts: 29
Joined: Mon Feb 07, 2005 4:16 am

Watch out for correct file name

Postby sturoc » Sat Apr 15, 2006 11:05 pm

After pulling my hair out for 5 min. I noticed that in Ike's post that the file name FLASHPREP is not used by EMU for their upgrade file name.
Don't know if they have changed it recently since Ike's post
the file names is now:



So take note of this otherwise you get the message unexecutable file/batch name etc...when typing DOS window to send it to the floppy.
(in W2000 pro)
Hope this helps
Posts: 150
Joined: Fri Jun 17, 2005 6:36 pm
Location: Colorado USA

Update and question

Postby tjm31 » Thu Sep 14, 2006 9:21 am


I am new here. Thanks for this walk through.

I have an e64 that was gotten off eBay with EOS v. 2.5f. EOS 4.10 classic will work on this machine according to EMU but I can't go any higher without more cpu rom. I tried to create a floppy for the 4.10 image on the emusonacid download page. The image is 1.88mb and won't fit on a standard DOS formatted 1.44mb floppy. It said it was 100% complete, but when I installed it on my e64, it gave me a checksum error and hosed the EOS. Thankfully EOS 2.8 is only 1.41mb. Loaded the floppy and restored the flash rom and now have EOS 2.8 on the system. So how did you guys get a 1.88mb flopyy image to load on your EIV whether classic or ultra?

Also, there is an error on the site as the EOS 3.0 zip file actually contains the Roland sdisk utility and docs. Does anyone have the EOS 3.0 file image? If I can't get up to 4.10 or higher without an expensive cpu rom upgrade, I would at least like to get to 3.0b which adds nice things like the arpeggiator or better yet the 4.02 which adds improved ESI and Akai importing. Does anyone have 4.02 as well?

Thanks for all the help...really appreciate it. It sucks that Emu has left us all out in the cold on these great Samplers:(

Posts: 2
Joined: Thu Sep 14, 2006 9:10 am

Re: *** EOS Upgrading *** PLEASE STICKY

Postby tez » Wed Jun 03, 2009 10:50 pm

Thought I'd post in this thread to new E-Mu owners trying to update their systems...

I have an E5000 Ultra that had EOS v4.10 and couldn't get it to recognize the update disks (flashprep and the OS). What it took to get the disks to recognize was formatting them with the E-Mu BEFORE writing the images.

Hopefully this saves some people some time!

Posts: 6
Joined: Mon Jun 01, 2009 10:33 pm


Return to EOS: The Knowledge